Add your own robot to the library
...a step by step guide...

The ARTE library has been designed to let the students add freely more robots
to the library. The following example presents how to do so:

1 Obtain 3D CAD files to represent the robot

Robot manufacturers provide 3D CAD files for their robots. They are in different
formats. Normally, you can either download separate files for each of the links
or the whole robot arm in a single file. You will find different CAD formats
available. You should choose the STL format preferably, in particular ASCII STL
format. In case you have downloaded the arm as a whole, divide it in their
independent links. Link0_base is the base, link1_base, link2_base ... etc. Each
of these links should be exported to STL (STereoLithography) format This is a
common format for many CAD software. You can find more information under
http://en.wikipedia.org/wiki/STL_(file_format)

For example, download the files for the ABB IRB6650S 90 390. Go into:
http://www.abb.com/product/us/9AAC910011.aspx

Or navigate to www.abb.com-> products—> robotics.

> IRB 6640 > IRB 6650S
Payload: 130 - 235 kg 7" Pay load: 125 - 200 kg
Reach: 2.55, 2.75, 2.8,3.2m é Reach:3.0m,3.5m

» IRB 6660 for press tending » IRB 6660 for pre machining

Pay load: 130 kg Pay load: 205 kg
Reach: 3.10 m 9 Reach: 1.93 m

» IRB 760 » IRB 7600
Pay load: 450 kg Pay load: 150 - 500 kg
Reach: 3.18 m Reach: 3.5, 3.1, 2.8, 2.55,

23m

Download CAD files. Beware of the robot version you are downloading. You
can either download the compl (whole arm), or joint (separate links). In this
example we will download the joint version. Extract the files and save them
under robot/abb/IRB6650S 90 390



IRB 6650S

PARA- ROB  Robot
Validation Ver. DWG sSw STEP SOLID VDA IGES STL VRML CAD Studio IGRIP
200-300 compl compl compl joint compl compl joint sim
125-350 sim
90-390 sim sim
2 Copy the files to the directory of your robot
You may place all the CAD files in the following directory:
Arte_libX.X/robots/abb/IRB6650S 90 390, if we have a look at it:
e 0o (21 IRB6650S_90_390
<> ERNVAERE - DIERIERIER (Q
FAVORITOS Im Contents.m (] abb » [ r8140 r 9 i 5_90-390_M2005_REV1_01-1.5TL
% Dropbox " COPYING.LESSER.txt (] example » (] IRB6620 » L 5_90-390_M2005_REV1_01-2.STL
" COPYING.txt (2 kuka » e 5_90-390_M2005_REV1_01-3.5TL
lemos » [ mitsubishi » £ 5_90-390_M2005_REV1_01-4.5TL
» [ stanford a 5_90-390_M2005_REV1_01-5.5TL
(2 unimar te o 5_90-390_M2005_REV1_01-6.5TL
P | _90-390_M2005_REV1_01-7.STL
L 1\stl\joints_lit _90-390_M2005_REV1_01-8.STL
@ Documentos L 1\stl\joints_| _90-390_M2005_REV1_01-9.5TL
E Peliculas L 1\stl\joints_| _90-390_M2005_REV1_01-10.STL
. i _| 5_90-390_M2005_REV1_01-11.5TL
a _90-390_M2005_REV1_01-12.5TL
o >_90-390_M2005_REV1_01-13.5TL
_ TODO_LIST L >_90-390_M2005_REV1_01-14.STL
(2 tools o 5_90-390_M2005_REV1_01-15.STL
COMPARTIDO o _90-390_M2005_REV1_01-16.STL
(2] Escritorio remoto de... m parameters.m

1 hamiltoniano's remot....

L2 Todo...
DISPOSITIVOS

|| Macintosh HD

) My Passport

[} MeshLabMac_v132

»o»

390

3955555555555 5 550>

abb\IRB6650S\M2005\REV1\stl\joints_links\IRB66505_90-390_M2005_REV1_01-1.STL
abb\IRB6650S\M2005\REV1\stl\joints_links\IRB6650S_90-390_M2005_REV1_01-2.STL
abb\IRB6650S\M2005\REV1\stl\joints_links\IRB6650S_90-390_M2005_REV1_01-3.STL
abb\IRB6650S\M2005\REV1\stl\joints_links\IRB6650S_90-390_M2005_REV1_01-4.STL
abb\IRB6650S\M2005\REV1\stl\joints_links\IRB66505_90-390_M2005_REV1_01-5.STL
abb\IRB6650S\M2005\REV1\stl\joints_links\IRB66505_90-390_M2005_REV1_01-6.STL
abb\IRB6650S\M2005\REV1\stl\joints_links\IRB6650S_90-390_M2005_REV1_01-7.STL
abb\IRB6650S\M2005\REV1\stl\joints_links\IRB6650S_90-390_M2005_REV1_01-8.STL
abb\IRB6650S\M2005\REV1\stl\joints_links\IRB66505_90-390_M2005_REV1_01-9.STL
abb\IRB6650S\M2005\REV1\stl\joints_links\IRB66505_90-390_M2005_REV1_01-10.STL
abb\IRB6650S\M2005\REV1\stl\joints_links\IRB6650S_90-390_M2005_REV1_01-11.STL
abb\IRB6650S\M2005\REV1\stl\joints_links\IRB6650S_90-390_M2005_REV1_01-12.STL
abb\IRB6650S\M2005\REV1\stl\joints_links\IRB66505_90-390_M2005_REV1_01-13.5TL
abb\IRB6650S\M2005\REV1\stl\joints_links\IRB66505_90-390_M2005_REV1_01-14.STL
abb\IRB6650S\M2005\REV1\stl\joints_links\IRB6650S_90-390_M2005_REV1_01-15.STL
abb\IRB6650S\M2005\REV1\stl\joints_links\IRB6650S_90-390_M2005_REV1_01-16.STL
parameters.m




You should also copy a parameters.m file belonging to other robot and
place it in the same directory.

Most CAD programs will read the STL files. For example, download and install
Meshlab: meshlab.sourceforge.net, for Windows, Mac or Linux. You
should now have a look at the files. In Meshlab, open each of the files to view
them. If you open the first file, you should find something like:

MeshLab v1

hFevcewse D BODDLY | > 3> X

Project_1

Mesh: abb\IRB6650S\M2005\REV 1\stoints_links\IRB6650S_90-390_M2005_REV1_01-1)
Vertices: 1326

Or, the second file:

MeshLab v1.3.2_64bit

DEFwvcovmsE e D BD@W ! | »3> X~

Mesh: abbURB6650S\M2005\REV 1\stjoints_links\IRB6650S_80-380_M2005_REV1_01-2
Vertices: 2030
Faces: 3788




Third file:

8 0 O MeshLab v1.3.2_64bit
hFwevceowmse DO BD@AUY ! > D> X
e OO0 Project_3

Mesh: abb\IRB6650S\M2005\REV 1\stNoints_links\RB6650S_80-380_M2005_REV1_01-
Vertices: 2669

N

The reader should observe that some of the files constitute the basic shape of
some of the robot links, whereas other files are details. You can merge some
files into a single file to obtain a more detailed view of any of the links. To do so,
you should have a look at the complete robot:




For example, start by opening the files with indexes 2, 8, 11, 12, 16. To do

so, click on File=> Import Mesh

I~

Select several files by clicking on Ctrl or cmd button.

0006 Import Mesh

[«]» ][22 m m || =~ || (]IRB6650S_90_390 ™ Q

FAVORITOS Nombre 4| Fecha de modificacion Tamafo Clase
(3 Dropbox 4 abb\IRB6650S\M2...005_REV1_01-1.STL  09/03/2006 13:18 746 KB STL 3D file
— @ abb\IRB66505\M2...005_REV1 01-2.STL  09/03/2006 13:18 1,1MB  STL 3D file
= Todos mis archivos 4 abb\IRB6650S\M2...005_REV1_01-3.STL  09/03/2006 13:18 1,5MB  STL 3D file
#% Aplicaciones @ abb\IRB6650S\M2...005_REV1_01-4.STL  09/03/2006 13:18 1,2MB  STL3D file
[ Escritorio & abb\IRB6650S\M2...005_REV1_01-5.STL  09/03/2006 13:18 2,6 MB  STL 3D file
[ Documentos & abb\IRB6650S\M2...005_REV1_01-6.STL  09/03/2006 13:18 1,6 MB  STL 3D file

& abb\IRB6650S\M2...005_REV1_01-7.STL  09/03/2006 13:18 420KB  STL 3D file

E Peliculas @ abb\IRB66505\M2...005_REV1_01-8.STL  09/03/2006 13:18 119KB  STL 3D file
JJ Misica & abb\IRB6650S\M2...005_REV1_01-9.STL  09/03/2006 13:18 91KB  STL3Dfile

) Imégenes

0 Descargas
COMPARTIDO

] hamiltoniano's re...

L Todo...

DISPOSITIVOS
|- Macintosh HD

L MuD a

STL 3D file
STL 3D file

@ abb\IRB6650S\M2...05_REV1_01-10.STL 09/03/2006 13:18
@ abb\IRB6650S\M2...05_REV1_01-11.STL 09/03/2006 13:18

93 KB
88 KB

@ abb\IRB66505\M2...05_REV1 01-12.STL 09/03/2006 13:18 90 KB STL 3D file
@ abb\IRB6650S\M2...05_REV1_01-13.STL 09/03/2006 13:18 111 KB STL 3D file
< abb\IRB6650S\M2...05_REV1_01-14.STL 09/03/2006 13:18 111 KB STL 3D file
@ abb\IRB6650S\M2...05_REV1_01-15.STL 09/03/2006 13:18 112 KB STL 3D file
@ abb\IRB66505\M2...05_REV1 01-16.STL 09/03/2006 13:18 243 KB STL 3D file
@ link1_base.stl hoy 18:11 1,5MB STL 3D file
m| parameters.m hoy 12:30 3 KB Objec...rce File

Carpeta nueva |

Files of type: | All known formats ( *.3ds *.ply... +

| Cancelar Open

For example, after opening the files with index 2, 8, 11, 12, 16, you should
have the following view of link 1.

600

MeshLab v1.3.2_64bit

NEE Q9 @

6 0 0

FOV: 60
FPS: 1923

DAL RABD > B - X

Project_14

Current Mesh: abbIRB6650S\M2005\REV 1\stNjoints_links\IRB6650S_90-390_M2005_REV1_01-16.STL
Vertices: 4 5?71
Faces: 842 (!




Next, open files 2, 8, 11, 12 and 16. Additionally, you should go to
Filters-> Layers-> Flatten visible layers

MeshLab File Editmkender View Windows Help

OO0 | Applyfilter Flatten Visible Layers 8L MeshLab v1.3.2_64bit
™ =3 N Show current filter script A g =
& e , @ L U B 7 Oo@® & 7
Selection > =
c > Cleaning and Repairing » oject 3 00

Create New Mesh Layer >
Remeshing, Simplification and Reconstruction > >[5 Mergec
Polygonal and Quad Mesh >
Color Creation and Processing >
Smoothing, Fairing and Deformation >
Quality Measure and Computations >
Normals, Curvatures and Orientation >

» Automatic pair Alignement
Raster Layer > CSG Operation
Range Map > Change the current layer
Point Set > Define New Per Face Attribute
Sampling > Define New Per Vertex Attribute
Texture > Delete Current Mesh

>

Camera Duplicate Current layer

Freeze CurrentFlatten all or only the visible
=i t I
Move selection afep "¢ @ single new
Rename CurrerTransformations are
preserved. Existing layers
Reset Current [C0% 0 ionally deleted
Split in Connected Components

generate a BNPTS file for out-of-core poisson

\

Next, click on Apply to combine the meshes.

© ) ) Flatten Visible Layers

Flatten all or only the visible
layers into a single new mesh.
Transformations are preserved.
Existing layers can be optionally
deleted

@] Merge Only Visible Layers
@] Delete Layers
121 Merge duplicate vertices

Keep unreferenced vertices

Default Help

Close Apply




Finally, save the file by selecting File>Export Mesh As. Select STL as format.
And name the file as link1_base.stl. The suffix base means that the points in the
STL file are referred to the base reference system.

O O O Save "abb\IRB6650S\M2005\REV1\stl\joints_links\IRB6650S_90-390_M2005...

Guardar como: Iinkl_base.stl|

= im || = v || (]IRB66505_90_390 s (Q

FAVORITOS [ ] IRB140 r abb\IRB66..._

[ Dropbox (] IRB6620 ’ abb\IRB66

L (] IRB66505_90_390 > abb\IRB66
# Aplicaciones abb\IRB66
=) abb\IRB66
abb\IRB66
abb\IRB66
& Peliculas abb\IRB66..._01-8.5TL
J7 Musica abb\IRB66..._01-9.5TL
abb\IRB66...01-10.STL
ahh\IRRAA N1-11 KTl
.2 Descargas All known formats ( *.3ds *.ply *.stl *.obj *.off *.wrl *.dxf *.dae *.ctm *.xyz *.gts *.json *.m *.u3d *.idtf *.x3d)

3D-Studio File Format ( *.3ds)
Files of typ¢ v Stanford Polygon File Format ( *.ply)

STL File Format ( *.stl)
Alias Wavefront Object ( *.obj)
Object File Format ( *.off)
VRML File Format ( *.wrl)
DXF File Format ( *.dxf)
Collada File Format ( *.dae)
OpenCTM compressed format ( *.ctm)
XYZ Point Cloud (with or without normal) ( *.xyz)
GNU Triangulated Surface ( *.gts)
JavaScript JSON ( *.json)
LiveGraphics3D applet ( *.m)
U3D File Format ( *.u3d)
IDTF File Format ( *.idtf)
X3D File Format ( *.x3d)

ﬁj Documentos

&) Imagenes

| Carpeta nueva |

Next, de-select the Binary encoding option, which stores the file in ASCII
format, that can be later read by Matlab.



©® O O Choose Saving Options for: 'abb\IRB6650S\M2005\REV1\stl\joints_links\IRB6650S_90-390_...

Vert Face Wedge Texture Name
T
Color Color Norma
Quality Quality FexCoord
Norma N 1
exCoo
A Rer I

Additional Parameters

Binary encoding

(o) All Camera
- - Help OK Cancel
None ’olygona

Repeat the process for the rest of the files. The table shows the file indices that
should be merged (flattenned) together.

Robot ARTE file Robot file index

link0_base.stl 1

Base, system O

link1_base.stl 2,8,11,12,16

Link 1, system 1.

link2_base.stl 3,9

Link 2, system 2.

link3_base.stl 4,10, 13

Link 3, system 3.

link4_base.stl 5,14, 15

link 4, system 4.

link5_base.stl 6
link 5, system 5.

link6_base.stl 7

link 6, system 6.




You can now try to visualize the files in Matlab. To do so, place the current
folder in arte_libX.X/robots/IRB6650S_90 390 and type the following
commands:

MATLAB 7.12.0 (R2011a)

Help

Current Folder: ‘IUsers/arturogiIaparicio/Desktop/arte_lib3.0/robots/abb/lRBGGSOS_90_390 v \\Z] =

X a =[O Command Window

ans =
/Users/arturogilaparicio/Desktop/arte_1lib3.0/robots/abb/IRB6650S_90_390

>> [fout, vout, cout] = stl read( linkl base.stl');
EndOfFile found... >>
>> draw_patch(fout, vout, cout,0)

S>> |

>>[fout, vout, cout] = stl read('link0O base.stl');

>>draw_patch(fout, vout, cout,0)

After calling the draw_patch function, the following figure appears:

—8'-0'6- — . — . i F-igurel-
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Please, note the scale (mm) and that the origin of the figure is not placed inside
the link (points are referred to the base reference system).

3 Transform the files to a different reference system

Now, you should edit the parameters.m file to include the basic parameters of
the arm, namely the D-H parameters, axes ranges, etc. In order to do so, copy
a parameters.m file from a different robot and edit it. You should read the
datasheet of the robot to obtain the main data.

From the datasheet, we observe the positive turn direction for each joint and the
main dimensions.
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Robot variant A

IRB 6650S-90/3.9 2042
IRB 6650S-125/3.5 1592
IRB 6650S-200/3.0 1142

In our case, A=2.042 meters. According to the version of the arm. Using the
drawing above, place the D-H systems and write a D-H table. A possible
placement for the standard D-H systems is shown next.



Which has the following D-H table associated:

2295.4

0 a o

o, 0.630 0.600 /2

0,-71/2 0 1.280 0

0 0 0.200 /2

0 2.042 0 /2

05 0 0 -/2
0.200 0 0




Edit the parameters.m file to indicate the previous table. Note the variables,
robot.DH.theta, robot.DH.d, etc.:

function robot = parameters()
robot.name= 'ABB_IRB6650S 90 390';

$Path where everything is stored for this robot
robot.path = 'robots/abb/IRB6650S 90 390';

robot.DH.theta= '[q(1l) q(2)-pi/2 q(3) a(4) q(5) q(6)]";
robot.DH.d='[0.630 0 0 2.042 0 0.2]';
robot.DH.a='[0.600 1.280 0.2 0 0 01';

robot.DH.alpha= '[-pi/2 0 -pi/2 pi/2 -pi/2 0]';

robot.J=[];

robot.inversekinematic_fn = 'inversekinematic irb6650S 90 390 (robot,
T)';

gnumber of degrees of freedom
robot.DOF = 6;

¢rotational: 0, translational: 1
robot.kind=['R' 'R' 'R' 'R' 'R' 'R'];

gminimum and maximum rotation angle in rad

robot.maxangle =[deg2rad(-180) deg2rad(180); %Axis 1, minimum, maximum
deg2rad(-40) deg2rad(160); %Axis 2, minimum, maximum
deg2rad(-180) deg2rad(70); %Axis 3
deg2rad(-300) deg2rad(300); %Axis 4:
deg2rad(-120) deg2rad(120); %Axis 5
deg2rad(-360) deg2rad(360)]; %Axis 6:

g¢maximum absolute speed of each joint rad/s or m/s
robot.velmax = [deg2rad(100); %Axis 1, rad/s
deg2rad(90); %Axis 2, rad/s
deg2rad(90); %Axis 3, rad/s
deg2rad(150); %Axis 4, rad/s
deg2rad(120); %Axis 5, rad/s
deg2rad(235)];%Axis 6, rad/s
% end effectors maximum velocity
robot.linear velmax = 0.0; %m/s, unavailable from datasheet

¢base reference system
robot.T0 = eye(4);

Each STL file stores the 3D position of a set of points belonging to the link in
coordinates of its own DH reference system. For example 1ink0.stl has the
position of the base points in coordinates of DH system 0. Linkl.stl stores
the position of the points belonging to link1 in coordinates of system 1, etc.
However, the files, link1_base.stl, link2_base.stl... etc store the points in the
base reference system. In addition, the units in this files are millimeters. The
function transform to_own will help you transform each stl file for each of




the reference systems, and at the same time, transform the scale to meters.
Before executing transform to own, you should have created the
robot.DH table before. The function reads the files IlinkO base.stl,
link1_base.stl... and transforms each link to its own D-H reference system.
Finally, the links are wrote to the same directory as linkO.stl, link1.stl, etc. Read
the transform_to_own help for more details.

>> help transform_to_own

Now, execute transform_to_own for the robot. You should obtain the following

>> transform_to own('abb', 'IRB6650S_90 390', 1000)
ans =

/Users/arturogilaparicio/Desktop/arte 1ib3.0/robots/abb/IRB6650S 90 39
0

Reading 1ink0_base.stlEndOfFile found... Wrote 2608 facets
Reading linkl base.stlEndOfFile found... Wrote 5674 facets
Reading link2 base.stlEndOfFile found... Wrote 5388 facets
Reading link3_base.stlEndOfFile found... Wrote 4764 facets
Reading link4 base.stlEndOfFile found... Wrote 9759 facets
Reading link5 base.stlEndOfFile found... Wrote 5522 facets
Reading link6_base.stlEndOfFile found... Wrote 1476 facets
4 Test everything

Test everything! First, load the robot:

>> robot=load robot('abb', 'IRB6650S 90 390');
ans =

/Users/arturogilaparicio/Desktop/arte 1ib3.0/robots/abb/IRB6650S 90 39
0

Reading 1link 0
EndOfFile found...
Reading link 1
EndOfFile found...
Reading link 2
EndOfFile found...
Reading 1link 3
EndOfFile found...
Reading link 4
EndOfFile found...
Reading 1link 5
EndOfFile found...
Reading link 6
EndOfFile found...

Now, you can use the teach GUI to test your robot. Use the sliders to move the
joints and test that everything is correct.

>> teach




¥(m)

X(m)

Large robots may require that you modify the axis in the matlab figure. Edit the
parameters.m file and modify the robot.axis variable:

| robot.axis=[-3 3 -3 3 0 3];

Set robot.graphical.draw_transparent=1 if you prefer to observe the D-H
systems and a transparent representation of the robot.

|>> robot.graphical.draw_transparent=1




X(m)

¥ (m)

5 What’s next?

During the next practical sessions you will modify the parameters.m file to
add more functionality to your robot, solving the inversekinematic problem,
adding dynamics and programming the robot.



